Wymagania systemowe rodziny produktów Visual Studio 2017 for Mac

Last Update: 2017-10-30

Poniżej przedstawiono minimalne wymagania systemowe rodziny produktów Visual Studio 2017 for Mac. Aby zainstalować program Visual Studio 2017 for Mac, zobacz Visual Studio 2017 — pliki do pobrania. Informacje o nowościach dostępnych w tej wersji można znaleźć w informacjach o wersji programu Visual Studio 2017. Zobacz również artykuł Obsługiwane platformy i zgodność programu Visual Studio 2017 for Mac.

Visual Studio 2017 for Mac

Następujące produkty obsługują poniższe minimalne wymagania systemowe:

  • Visual Studio Enterprise 2017 for Mac.
  • Visual Studio Professional 2017 for Mac.
  • Visual Studio Community 2017 for Mac.

Obsługiwane systemy operacyjne

Program Visual Studio 2017 for Mac można zainstalować i uruchamiać w następujących systemach operacyjnych:

  • macOS Sierra 10.12: Community, Professional i Enterprise.
  • Mac OS X El Capitan 10.11: Community, Professional i Enterprise*.
* najnowsza wersja programu Xcode 8.3 wymaga systemu macOS Sierra 10.12, dlatego projekty platform Xamarin.iOS i Xamarin.Mac również wymagają tej minimalnej wersji

Sprzęt

  • Procesor 1,8 GHz lub szybszy (zalecany dwurdzeniowy lub lepszy).
  • 4 GB pamięci RAM; zalecane 8 GB pamięci RAM (co najmniej 4 GB w przypadku uruchamiania na maszynie wirtualnej).
  • Miejsce na dysku twardym: około 1 GB.

Obsługiwane języki

Program Visual Studio for Mac jest dostępny w następujących językach:

  • angielski, chiński (uproszczony), chiński (tradycyjny), czeski, francuski, hiszpański, japoński, koreański, niemiecki, polski, portugalski (Brazylia), rosyjski, turecki i włoski.

Wymagania dodatkowe

  • Do korzystania z projektów i funkcji platformy .NET Core wymagany jest zestaw SDK platformy .NET Core w wersji 1.1. Można go pobrać i zainstalować oddzielnie. Wymaga on systemu Mac OS X El Capitan 10.11 lub jego nowszej wersji.
  • Platforma Xamarin.Android wymaga 64-bitowego zestawu deweloperskiego Java Development Kit (JDK).
  • Platforma Xamarin.iOS wymaga środowiska IDE programu Xcode i zestawu SDK systemu iOS firmy Apple.
  • Platforma Xamarin.Forms obsługuje zarówno platformę Android, jak i platformę iOS, o ile są spełnione podane powyżej wymagania.