Visual Studio 2017 for Mac 产品系列系统要求

Last Update: 2017/10/30

下面是 Visual Studio 2017 for Mac 系列产品的最低系统要求。 若要安装 Visual Studio 2017 for Mac,请参阅 Visual Studio 2017 下载。 有关此次发布版新增功能的详细信息,请参阅 Visual Studio 2017 发行说明。 另请参阅 Visual Studio 2017 for Mac 平台目标以及兼容性

Visual Studio 2017 for Mac

以下产品支持下面的最低系统要求:

  • Visual Studio Enterprise 2017 for Mac。
  • Visual Studio Professional 2017 for Mac。
  • Visual Studio Community 2017 for Mac。

支持的操作系统

Visual Studio 2017 for Mac 可在以下操作系统上安装并运行:

  • macOS Sierra 10.12:社区版、专业版和企业版。
  • Mac OS X El Capitan 10.11:社区版、专业版和企业版*。
最新版本的 Xcode 8.3 需要 macOS Sierra 10.12,因此 Xamarin.iOS 和 Xamarin.Mac 项目也需要该最低版本

硬件

  • 1.8 GHz 或更快的处理器。 双核或更好的建议。
  • 4 GB RAM;建议 8 GB RAM(如果在虚拟机上运行,则最低 4 GB)。
  • 硬盘空间:大约 1 GB。

支持的语言

Visual Studio for Mac 提供了以下语言版本:

  • 英语、简体中文、繁体中文、捷克语、法语、德语、意大利语、日语、韩语、波兰语、葡萄牙语(巴西)、俄语、西班牙语和土耳其语。

其他要求*

  • 使用 .NET Core 项目和功能需要 .NET Core SDK 1.1。 下载和安装可以分别进行,需要 Mac OS X El Capitan 10.11 或更高版本。
  • Xamarin.Android 需要 64 位版本的 Java 开发工具包 (JDK)。
  • Xamarin.iOS 需要 Apple 的 Xcode IDE 和 iOS SDK。
  • Xamarin.Forms 可以面向 Android 和 iOS 平台,只需满足上述要求即可。