Visual Studio 2017 제품군 시스템 요구 사항

Last Update: 2017-09-01

Visual Studio 2017 제품군에 대한 최소 시스템 요구 사항은 아래에 나와 있습니다. 호환성에 대한 내용은 Visual Studio 2017 플랫폼 대상 지정 및 호환성을 참조하세요.

새로운 기능

이 릴리스에 포함된 기능에 대한 내용은 다음을 참조하세요.

다운로드

Visual Studio 2017을 설치하려면 Visual Studio 2017 다운로드를 참조하세요.

이전 버전

이전 버전의 Visual Studio의 경우 Visual Studio 2015, Visual Studio 2013 또는 Visual Studio 2012에 대한 시스템 요구 사항을 참조하세요.

피드백 및 지원

지원이 필요하거나 Visual Studio에 대한 피드백을 제출하려면 다음을 참조하세요.

Visual Studio 2017 시스템 요구 사항

다음 제품이 아래의 최소 시스템 요구 사항을 지원합니다.

  • Visual Studio Enterprise 2017
  • Visual Studio Professional 2017
  • Visual Studio Community 2017
  • Visual Studio Test Professional 2017
  • Visual Studio Test Agent 2017
  • Visual Studio Test Controller 2017
  • Visual Studio Team Foundation Server Office Integration 2017
  • Visual Studio Feedback Client 2017

지원되는 운영 체제

Visual Studio 2017은 다음 운영 체제에서 설치되고 실행됩니다.

  • Windows 10 버전 1507 이상: Home, Professional, Education 및 Enterprise(LTSB 및 S는 지원되지 않음)
  • Windows Server 2016: Standard 및 Datacenter
  • Windows 8.1(업데이트 2919355 포함): Core, Professional 및 Enterprise
  • Windows Server 2012 R2(업데이트 2919355 포함): Essentials, Standard, Datacenter
  • Windows 7 SP1(최신 Windows 업데이트 포함): Home Premium, Professional, Enterprise, Ultimate

하드웨어

  • 1.8GHz 이상의 프로세서 듀얼 코어 이상 권장
  • RAM 2GB. 4GB의 RAM을 권장함(가상 컴퓨터에서 실행하는 경우 최소 2.5GB)
  • 하드 디스크 공간: 설치한 기능에 따라 1GB~40GB
  • 최소 디스플레이 해상도 720p(1280x720)를 지원하는 비디오 카드. Visual Studio는 WXGA(1366x768) 이상 해상도에서 가장 잘 작동합니다.

지원되는 언어

Visual Studio는 다음 언어로 제공됩니다.

  • 영어, 중국어(간체), 중국어(번체), 체코어, 프랑스어, 독일어, 이탈리아어, 일본어, 한국어, 폴란드어, 포르투갈어(브라질), 러시아어, 스페인어, 터키어

설치하는 동안 Visual Studio 언어를 선택할 수 있습니다. Visual Studio 설치 관리자는 동일한 14개 언어로 제공되며 가능하면 Windows 언어에 맞춥니다.

참고: Visual Studio Team Foundation Server Office Integration 2017은 Visual Studio Team Foundation Server 2017에서 지원하는 10개 언어로 제공됩니다.

추가 요구 사항

  • Visual Studio를 설치하려면 .NET Framework 4.5가 필요합니다. Visual Studio에는 .NET Framework 4.6.1이 필요하며 이 프레임워크는 설치 과정에서 설치됩니다.
  • 개발에는 Windows 10 Enterprise LTSB 버전Windows 10 S가 지원되지 않습니다. Windows 10 LTSB 및 Windows 10 S에서 실행되는 앱을 빌드하는 데 Visual Studio 2017을 사용할 수 있습니다.
  • 인터넷 관련 시나리오에는 Internet Explorer 11 또는 Edge가 필요합니다. 일부 기능은 이러한 항목 또는 최신 버전이 설치되어 있지 않으면 작동하지 않을 수 있습니다.
  • 에뮬레이터를 지원하려면 Windows 8.1 Pro 또는 Enterprise(x64) 버전이 필요합니다. 클라이언트 Hyper-V 및 SLAT(두 번째 수준 주소 변환)를 지원하는 프로세서도 필요합니다.
  • 유니버설 Windows 앱 개발(디자인, 편집, 디버깅 포함)을 하려면 Windows 10이 필요합니다. 명령줄에서 유니버설 Windows 앱을 빌드하는 데 Windows Server 2016 및 Windows Server 2012 R2를 사용할 수 있습니다.
  • Windows Server를 실행하는 경우 [Server Core] 및 [Minimal Server Interface](최소 서버 인터페이스) 옵션이 지원되지 않습니다.
  • Team Foundation Server 2017 Office Integration을 사용하려면 Office 2016, Office 2013 또는 Office 2010이 필요합니다.
  • Xamarin.Android에는 64비트 버전의 Windows 및 64비트 JDK(Java 개발 키트)가 필요합니다.
  • C++, JavaScript 또는 .NET 워크로드를 사용하여 모바일 개발을 설치하려면 Windows 7 SP1에 PowerShell 3.0 이상이 필요합니다.

Visual Studio Team Foundation Server 2017

다양한 배포 시나리오에 대한 시스템 요구 사항과, Microsoft Office 및 Microsoft SharePoint와의 통합에 대한 자세한 내용은 Visual Studio Team Foundation Server Requirements and Compatibility(Visual Studio Team Foundation Server 요구 사항 및 호환성)를 참조하세요. 다음 제품이 아래의 최소 요구 사항을 지원합니다.

  • Visual Studio Team Foundation Server 2017
  • Visual Studio Team Foundation Server Express 2017

지원되는 운영 체제

Visual Studio Team Foundation Server 2017은 다음 운영 체제의 64비트 버전에서 설치되고 실행됩니다.

  • Windows 10 버전 1507 이상: Home, Professional 및 Enterprise
  • Windows Server 2016: Standard 및 Datacenter
  • Windows Server 2012 R2(업데이트 2919355 포함): Essentials, Standard, Datacenter
  • Windows 8.1(업데이트 2919355 포함): Core, Professional 및 Enterprise
  • Windows Server 2012: Essentials, Standard, Datacenter
  • Windows Server 2008 R2 SP1: Standard, Enterprise, Datacenter
  • Windows 7 SP1(최신 Windows 업데이트 포함): Home Premium, Professional, Enterprise, Ultimate

하드웨어

단일 서버 및 다중 서버 배포에 대한 하드웨어 권장 사항은 Visual Studio Team Foundation Server Requirements and Compatibility(Visual Studio Team Foundation Server 요구 사항 및 호환성)를 참조하세요.

지원되는 언어

Visual Studio Team Foundation Server는 다음 언어로 제공됩니다.

  • 영어, 중국어(간체), 중국어(번체), 프랑스어, 독일어, 이탈리아어, 일본어, 한국어, 러시아어, 스페인어

추가 요구 사항

  • .NET Framework 4.6.1(설치 과정에서 설치됨)
  • Microsoft SQL Server 2014 또는 Microsoft SQL Server 2016
  • Team Foundation Server Web Client를 사용하려면 Microsoft Edge, Internet Explorer 11, Google Chrome, Mozilla Firefox 또는 Apple Safari가 필요합니다.
  • Team Foundation Server Office Integration을 사용하려면 Office 2016, Office 2013 또는 Office 2010이 필요합니다.

Mac용 Microsoft Visual Studio 2017

Mac용 Visual Studio 2017 다운로드 자세한 내용은 Mac용 Visual Studio 2017 릴리스 정보, Mac용 Visual Studio 2017 제품군 시스템 요구 사항Mac용 Visual Studio 2017 플랫폼 대상 지정 및 호환성을 참조하세요.

Microsoft Visual Studio Code

Visual Studio Code를 다운로드합니다. 자세한 내용은 Visual Studio Code에 대한 요구 사항, 릴리스 정보Visual Studio Code FAQ를 참조하세요.

Visual Studio 2017용 원격 도구, 성능 도구 및 IntelliTrace 수집기

원격 도구, 성능 도구 및 IntelliTrace 수집기는 Visual Studio와 동일한 시스템 요구 사항을 지원합니다. 단, 다음과 같은 몇 가지 변경 사항이 있습니다.

  • 또한 Windows 10 Enterprise LTSB, Windows Server 2012 및 Windows Server 2008 R2 SP1에도 설치됨
  • 프로세서 1.6GHz 이상이 필요함
  • 1GB RAM(가상 컴퓨터에서 실행하는 경우 1.5GB)이 필요함
  • 1GB의 사용 가능한 하드 디스크 공간이 필요함
  • 1024x768 이상의 디스플레이 해상도가 필요함
  • 환경을 최적화하려면 해당 Visual Studio 버전에 맞는 이러한 진단 도구의 최신 업데이트를 사용하세요.

Microsoft Visual Studio Build Tools 2017

Build Tools는 Visual Studio와 동일한 시스템 요구 사항을 지원합니다. 단, 다음과 같은 몇 가지 변경 사항이 있습니다.

  • Windows Server 2008 R2 SP1에도 설치함
  • 250MB~2.1GB의 사용 가능한 하드 디스크 공간이 필요함

Visual Studio 2017용 Microsoft Visual C++ 재배포 가능 패키지

Visual C++ 재배포 가능 패키지는 Visual Studio와 동일한 시스템 요구 사항을 지원합니다. 단, 다음과 같은 몇 가지 변경 사항이 있습니다.

  • 또한 Windows 10 Enterprise LTSB, Windows Server 2012, Windows Server 2008 R2 SP1, Windows Vista SP2, Windows Server 2008 SP2, Windows Server 2003 SP2 및 Windows XP SP3에도 설치됨
  • 1GB RAM(가상 컴퓨터에서 실행하는 경우 1.5GB)이 필요함
  • 50MB의 사용 가능한 하드 디스크 공간이 필요함
위쪽